1993 W250 skips 2nd under WOT

How they work, how they don't work, and how to fix them

Moderators: Greenleaf, BC847, Richie O

1993 W250 skips 2nd under WOT

Postby adcotton » Sat Dec 03, 2016 6:51 pm

1993 w250 cummins pickup. Has tight aftermarket converter.

since i got the truck second seemed short, And under WOT first hangs then directly hits third, skipping second.
Had transmission rebuilt by a reputable shop with a "superior" shift kit, superhold servo.

Same issue persists. brought it back and told them to drive it wide open. which they did and he saw the problem. They eventually decided the valve body must be bad internally as the valves are not sticking. replaced valvebody (put shift kit into new valve body) and problem still persists.
he is in his words working "dilligently" to figure it out.

TV cable has been adjusted to move as soon as throttle is worked and also loosened up to give some throttle before TV is actuated.
very little difference noticed. when the tV cable is tight i also expirience more governer sticking symptoms . clunking into first once stopped or taking off in 2nd or 3rd. notice less of this with looser TV cable settings.

Also the tv cable does not have the throw that the throttle does. So the TV cable limits throttle action when adjusted so that the TV cable moves as soon as throttle is depressed. Still hits the same 38 PSI of boost adjusted either way.


Hoping someone has an idea as i am $2,400 into this transmission and not getting to enjoy it at all...

please advise if you have any idea what i can tell the transmission guy to check!!
adcotton
fuel pin?
 
Posts: 21
Joined: Sat Jan 31, 2015 8:19 am
Location: Southern Maine

Re: 1993 W250 skips 2nd under WOT

Postby adcotton » Mon Dec 05, 2016 6:55 pm

Also has rpm flare when manually shifted from 2 to 3
adcotton
fuel pin?
 
Posts: 21
Joined: Sat Jan 31, 2015 8:19 am
Location: Southern Maine

Re: 1993 W250 skips 2nd under WOT

Postby DodgeFreak » Mon Dec 12, 2016 7:29 am

Make sure the bands are adjusted right. Have them do all the pressure checks also. not sure what else it could be. I would have a stock valve body put in without a shift kit and see if that fixes it and it will tell you if its in the vb\shiftkit or trans its self.
92 D350 Cab and Chassis. Auto stock, wiring gremlins. 330k miles
92 W250 Ext cab rotted completely out. Auto, pump maxed, 215 ppump nozzles, Denny T2 pin.
85 D350 single wheel, converted to cummins, getrag, turned up 2 turns and afc screw flush.
User avatar
DodgeFreak
14mm rotor
 
Posts: 1701
Joined: Sat May 15, 2010 8:14 pm
Location: Iowa
Top

Re: 1993 W250 skips 2nd under WOT

Postby adcotton » Sun Dec 25, 2016 10:12 pm

Swapping the superior shift kit for a transgo fixed the shifting. Drove it about 75 miles everything seemed nice then started sounding like a bearing going which apparently was the pump in my transmission. Sticking governer quickly followed by no second gear ..back to the shop again. Hopefully the third try is the charm.
adcotton
fuel pin?
 
Posts: 21
Joined: Sat Jan 31, 2015 8:19 am
Location: Southern Maine
Top


Return to Transmission

Who is online

Users browsing this forum: No registered users and 4 guests

cron